Magento 1.9 is beschikbaar

Gisteren ( 13 mei 2014 ) hebben de mensen achter het eCommerce platform Magento versie 1.9 uitgebracht voor zowel de CE (Community Edition) alsmede voor de Enterprise versies. Er zijn uiteraard weer een aantal bugs opgelost en een aantal nieuwe features toegevoegd. 1 van deze nieuwe features is dat Magento vanaf versie 1.9 standaard ondersteuning biedt voor PHP 5.4.

Magento 1.9 is vanaf 13 mei 2014 te gebruiken

Magento 1.9 is vanaf 13 mei 2014 te gebruiken

Voordat versie 1.9 van Magento was uitgebracht was het niet mogelijk om de webwinkel software werkend te krijgen wanneer je gebruik maakt van PHP 5.4. De standaard Magento opzet en templates zijn aangepast zodat deze werken volgens een responsive web design methodiek. Hieronder bevinden zich de meest belangrijke wijzigingen die mee komen in deze update:

  • Het standaard thema in Magento community edition 1.9 maakt gebruik van responsive web design principes om een betere ervaring voor gebruikers van onder andere mobiele apparaten te geven. Een aantal voordelen hiervan zijn:
  • Je kunt een smartphone en tablet vriendelijke responsive web winkel hebben in ongeveer de helft van de tijd als voorheen, dit zorgt voor meer tijd om je webwinkel daadwerkelijk in te richten en je meer te focussen op marketing in plaats van development.
  • Je responsive webwinkel zorgt ervoor dat je beter mee kunt doen met je webwinkel in de snelle on-line eCommerce wereld. Dit geeft je de mogelijkheid om je webshop sneller aan te passen aan eventuele toekomstige wijzigingen, daarbij is het minder duur om deze wijzigingen door te voeren en te onderhouden. Een responsive webshop biedt ook betere potentie voor zoekmachine optimalisatie (SEO) daar Google een voorkeur heeft voor responsive webwinkels dan reguliere.

Grensoverschrijdende handel: ook wel gerefereerd als prijs consistentie. Wanneer je op zoek bent om voor bijvoorbeeld webwinkeliers in de EU de mogelijkheid te bieden om de klanten dezelfde prijs te geven ongeacht de geografische locatie. Het aanmaken van deze prijzen is makkelijk en overzichtelijk in tegenstelling tot het bijhouden van een hele reeks BTW regels die verschillen per land. Om grensoverschrijdende handel (cross-border trade) aan te zetten in Magento 1.9 navigeer je naar System -> Configuration -> Sales -> Tax -> Calculation Settings en vink de optie “Enable Cross Border Trade” aan.

Magento 1.9 ondersteunt PHP 5.4 samen met een aantal security fixes voor onder andere XSS aanvallen wanneer je een configureerbaar product aanmaakt en een aantal andere: zoals hier onder te lezen is (Engels):

  • Addressed a potential cross-site scripting (XSS) vulnerability while creating configurable product variants.
  • Addressed a potential security issue that could result in displaying information about a different order to a customer.
  • Users can no longer change the currency if the payment method PayPal Website Payments Standard is used.
  • Removed an .swf file from the Magento distribution because of security issues.
  • Improved file system security.
  • Enhanced the security of action URLs, such as billing agreements.
  • Addressed a potential session fixation vulnerability during checkout.
  • Improved the security of the Magento randomness function.

Download de meest recente versie van Magento via: http://www.magentocommerce.com/download of lees meer op de officiele website van Magento ecommerce via: http://www.magentocommerce.com/knowledge-base/entry/ce19-later-release-notes

1 antwoord

Geef een reactie

Het e-mailadres wordt niet gepubliceerd. Vereiste velden zijn gemarkeerd met *