Afbeeldingen worden niet getoond in Magento

Zoals sommige van jullie weten werk ik vaak met Magento. Hierbij loop ik wel eens tegen een aantal problemen aan, zoals het probleem dat afbeeldingen niet worden getoond aan de voorkant (frontend) van je webwinkel. Gelukkig kan ik je bieden, lees in dit artikel hoe je ervoor kunt zorgen dat de afbeeldingen van je Magento webshop weer worden getoond!Ik heb een verse Magento installatie (versie 1.8.1.0) draaien op een shared omgeving (bij TransIP). Dit gaf de nodige errors tijdens de installatie, het probleem dat er geen afbeeldingen worden getoond heeft hier mee te maken. Het leek erop dat ik op geen enkele manier de afbeeldingen aan de frontend kant werkend zou krijgen.

De afbeeldingen waren juist geupload (via de admin). Dat kon ik namelijk zien door even in te loggen op de FTP en te navigeren naar media/uploads/catalog/… en het bestand te downloaden. Het zou zomaar kunnen dat het bestand corrupt is geraakt tijdens het uploaden (hoe vreemd ook).

Desalniettemin; de simpele fix voor dit probleem is:

hernoem het .htaccess bestand in de /media map naar .htaccess-oud. Dit zal ervoor zorgen dat je afbeeldingen weer juist worden getoond!

Hopelijk helpt deze tip je zodat je niet heel veel websites hoeft te bezoeken om achter de oplossing voor dit probleem te komen! Heb jij zelf nog een handige Magento tip? Laat het ons weten door een reactie te geven aan de hand van het reactieformulier op deze pagina.

12 antwoorden

  1. reintkoning1989Reint 5 mei 2014 / 10:33 am

    Super dankjewel!

  2. Marko 17 maart 2015 / 7:00 pm

    Marco,

    ik zie nergens het .htaccess bestand staan. Weet je waar ik deze kan vinden?

    • Marco Bax 20 maart 2015 / 9:17 am

      Beste Marko, het .htaccess bestand bevind zich in de root van je project. Meestal is dat /http-docs of /www. Je kunt dit bestand aanmaken, mocht deze zich niet bevinden in deze mappen.

  3. Femke 2 april 2015 / 7:59 pm

    Heb je toevallig ook ervaring met het plotseling (oke na wat extensies verwijderen en toevoegen, dat wel) niet meer uploaden van images? ik kan ze ‘browsen’dan komen ze netjes in de backend bij product te staan, en dan kan ik ze niet uploaden, dat doet die niet meer, gisteren nog wel. Ik heb geen flauw benul waar ik het moet zoeken.

    • Marco Bax 15 april 2015 / 7:58 pm

      Beste Femke, helaas kan dit een hele hoop redenen hebben. Ik hoop dat het probleem inmiddels verholpen is.

      • Femke 26 april 2015 / 5:29 pm

        Nog steeds niet, kan het zijn dat ik een cache geleegd heb op de verkeerde manier?
        dat denk ik nu namelijk.

  4. lieve 22 april 2016 / 6:44 am

    Heb je toevallig ervaring met het ‘ afbeelding niet kunnen uploaden’ vanuit een MACbook in Magento? Ik kan het wel met de ‘vaste pc MAC’ maar niet vanuit mijn laptop.

  5. Jasper 7 november 2016 / 4:08 pm

    Goedemiddag Marco,
    Wellicht heb je een oplossing op een probleem dat ik heb;
    Ik heb afbeeldingen geupload vanuit mijn voorraadbeheer. Deze komt netjes bij het product bij de afbeeldingen. Echter staat standaard ‘geen afbeelding’ aangevinkt in plaats van de productfoto. Kan ik dit in één keer aanpassen zonder langs alle producten te moeten?

    • Marco Bax 20 november 2016 / 11:03 am

      Beste Jasper, in een standaard Magento installatie is het zo dat je dit handmatig moet doen. In de meeste gevallen los je dit op door gebruik te maken van een script of plugin. Probeer op het forum van Magento eens te vragen of iemand daar een geschikte plugin voor heeft.

Geef een reactie

Het e-mailadres wordt niet gepubliceerd. Vereiste velden zijn gemarkeerd met *